Welcome, Guest
Username Password: Remember me

blocking domains aint working
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: blocking domains aint working

Re:blocking domains aint working - Solved!? 10 years, 11 months ago #354

Thanks again.

I'll look at the code and incorporate the Botscout check (with option to disable in the plugin admin options). With the other features I've added, the next release will be a pretty big one now!

Re:blocking domains aint working - Solved!? 10 years, 11 months ago #357

  • carmanml
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Thanks for the great work you're doing. I can't wait for the update. I have a question, though. Will we be able to block IP's and domains by wildcard? For instance, will I be able to block everyone from the 192.168.0.0 Class B, or everyone registering with a .ru email address?

Re:blocking domains aint working - Solved!? 10 years, 11 months ago #358

Domains can be blocked by entering as much of the right-hand as you like, so you can block .ru byt just entering that. I'll need to look into being able to block IPs by block.

It's my thanks to JDaniels for a lot of the work on this release. It will have some unexpected fixes and extra features due to his help. I'll tie everything together and upload the new release over the weekend.

Re:blocking domains aint working - Solved!? 10 years, 11 months ago #361

I've just uploaded the latest version, and also changed the name as the plugin no longer simply blocks disposable addresses.

I've added all the planned features, and tested them - all seem to be working fine!

It is already in use on this site. Thanks again JDaniels for your help with the SEF fix and the Botscout integration.

Re:blocking domains aint working 10 years, 10 months ago #409

  • zebrafilm
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
I am not sure about what version this thread is but I have installed the plugin v 1.1.2 on a few of my Joomla sites and it is not working on any of them.

They are all the latest version, (currently 1.5.14), running on different server systems (Windows Server 2008 and UNIX)

I have added and enabled the API key and switched all options on. When I enter email adresses in the blocklist, they are still alowed to send emails.
This counts for full emails as well as for parts of it.
When I use an email that matches the build in blacklist it also doen't work.
It seems not able to detect the contact forms info.

I appreciate your work very much and would like to use it on many sites. Please let me know how I can help you to find the problem.

Bastiaan

Re:blocking domains aint working 10 years, 10 months ago #410

I take it that it is contact form blocking you are wanting to implement? Does the blocking work for the registration sign-up, or does it seem to be not working at all?

I added the contact form integration so that I could get rid of the captcha on my site. I did some basic tests on my site, and it works fine for me - but I do only have one contact (me), so it isn't what I'd call in-depth testing.

Do you use the standard Joomla contact forms? The plug-in should be able to trap and validate these (shouldn't matter if there is more than one, either), but it will not work with others. Also, it is only implemented against the contact pages that are created in the back-end.

Please let me know how you have implemented your contact pages, and I'll run some further tests on my dev site to see if I can replicate the problem.

Re:blocking domains aint working 10 years, 6 months ago #672

  • novateca
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
hi!

I'm new to this site, so please forgive me if i'm asking something obvious...

this plugin works with the joomla contact form? did you get to make the test if more than one address are on one page? is there a "better way" to configure the joomla contact form so the plugin will work all right?

thanks a lot!!

Re:blocking domains aint working 10 years, 6 months ago #673

For contact forms, I have only tested with standard Joomla contact forms. It works by intercepting the contact form on submission, and will then do the same email/ip checks as for registration, and optionally extra checks on the content of the message (e.g. checks for links).

Not sure what you mean by more than one address on one page? If you look at the Contact page of this site, it is that Joomla form that is being protected - currently no others.

Re:blocking domains aint working 10 years, 6 months ago #674

  • novateca
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
thanks! ok... got it.... and don't worry about the "more than one address"... it was me confusing things... maybe too late to write...

thanks again for such a quick response!

Re:blocking domains aint working 10 years, 4 months ago #776

  • brigitte
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Hi, I can't get this plugin to work either...it is enabled and set "first" in order. I am trying to block a particular domain (text2re.com) in the standard joomla registration form, am running version 1.5.10 in legacy mode. Any suggestions please?

Re:blocking domains aint working 10 years, 4 months ago #777

So you added .text2re.com to the list of blocked domains? The preceding . will block all subdomains as well - if you just add textre.com to the blocklist, only that domain will be blocked.

Can you see .text2re.com in the blocklist when you go into the plugin parameters?

Re:blocking domains aint working 10 years, 4 months ago #778

  • brigitte
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
hi, thanks for your reply. text2re was already in the blocklist of the plugin, so all I had to do was enable it really. Tried turning off some of the other parameters but I can still register This e-mail address is being protected from spambots. You need JavaScript enabled to view it

Re:blocking domains aint working 10 years, 4 months ago #779

I've just installed 1.2.8 on my test site (test.cedit.biz) and enabled it - I can't replicate the problem. It blocks the address as it should do.

Could you enable logging on your server to see if that throws any light on the issue? I'm not sure what could cause the problem currently, as the internal blocklist (which text2re.com is on) doesn't rely on any external services at all so shouldn't have a problem.

Re:blocking domains aint working 10 years, 4 months ago #780

  • brigitte
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Hi again, don't think I can enable logging as I am using shared hosting? Cheers.

Re:blocking domains aint working 10 years, 4 months ago #781

Shared hosting shouldn't matter as long as you have access to your site to be able to create a folder for the logs and grant the necessary permissions. This site is on a shared server. Without logs I'm not sure how much help I can give. The only other option would be to give me administrative access to Joomla on the problem site so I can see if I can isolate the problem that way. If you want to do this, you can email or pm me the details and I can take a look.

Re:blocking domains aint working 10 years, 4 months ago #782

  • brigitte
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
I think the issue might be related to a component "TPLancers" I have on my site, as a direct hack to the core also doesn't work when blocking domains. I will try and find the file which controls registration! Thanks for your help.

Re:blocking domains aint working 10 years, 4 months ago #783

Thanks for the update. If you could let me know when you isolate the problem that would be useful in case anyone else comes up against the issue.

If you could point me at a download page for TPLancers, I could see if I can modify RV to work with it. I did google the component, but while I found lots of references, I can't seem to find where it is obtained.

Re:blocking domains aint working 10 years, 4 months ago #799

  • brigitte
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Hi, its a club template from Template Plazza, so you need to pay to download it. A demo is here demo.templateplazza.net/?template=freelance_plazza

I will let you know once I have found the solution and post it here

Re: blocking domains aint working 8 years, 9 months ago #1907

  • memo12
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hi,

It doesn't work for me either which is a shame, the idea is perfect for people who have template/captcha conflicts.

If anyone figures out why it doesn't work for a few of us I would be very interested to know of a fix!
  • Page:
  • 1
  • 2
Time to create page: 0.44 seconds
Copyright © 2009 www.cedit.biz. All rights reserved.