Welcome, Guest
Username Password: Remember me

After installation how to use/configure it?
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: After installation how to use/configure it?

After installation how to use/configure it? 10 years ago #1569

  • lifemedia
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
I have installed this plugin...
Installation was successful.
But stuck there...
Does any one tell me, how can i use/configure it please??
Really appreciate your response..
Thank you.

Sunil

Re: After installation how to use/configure it? 10 years ago #1570

It will block spammers under default configuration. To change any settings, do this from the Plugin Parameter page - they are all fairly straightforward (some require you to register with other sites to obtain a key).

You must ensure that RV is the highest priority plugin for it to be effective.

Re: After installation how to use/configure it? 9 years, 8 months ago #1801

  • richmarx
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Parameter page - they are all fairly straightforward


I can't say I agree. Out of the box joomla registrations were rejected with gmail & yahoo addresses (by stopforumspam).

Now if the plugin can't access any of the servers (extremely unlikely) then does the plugin block or allow the registration?

What I'd like to avoid is having to go to all of the websites your plugin uses to validate an email address and read up on all of the options, configurations etc just to block the spammers.

Any help you can provide would be appreciated. It would be great to have a README or doc that covers the absolute basics of each of the spam blocking services your plugin utilizes.

Great contribution though. I'm sure I'll be very happy when I can enable the plugin.
Oh and as for making the plugin the highest priority, it is ordered as #0, but then so are other plugins. In the System category I think it is the only one ordered as 0.

Re: After installation how to use/configure it? 9 years, 8 months ago #1802

If the plugin cannot access a service, then the registration will NOT be blocked by that service. A registration is only blocked if it receives a negative answer (i.e. IS a spammer). Any other answer (or lack of) will allow the registration to proceed.

All the spam blocking services used are essentially databases. If the registration details (IP or email address) are found in one of these databases, the registration is blocked.

Many spammers use gmail and yahoo addresses - so it isn't surprising that addresses from these providers have been blocked.

As far as the services go, RV pretty much either uses a service or doesn't - there is very little to configure other than this. The only service that requires a little more configuration is Akismet, and I don't actually recommend that this service is enabled because of this - RV doesn't support most of the features that actually make Akismet effective, so in my testing Akismet hasn't been.

The only time I have seen the plugin priority be an issue is if the Azrul System Mambot (from JomSocial) is higher priority. Under most other conditions, RV acts as expected (e.g. if it is the same priority as the system plugins, as in your case).
Last Edit: 9 years, 8 months ago by purplepomegranite.

Re: After installation how to use/configure it? 9 years, 8 months ago #1803

  • richmarx
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Thanks for the info, it does clarify things. I'll investigate further. Perhaps it has to do with the version of various components I am running.

CB 1.4.0 (latest)
Joomla 1.5.22
Kunena 1.6.3
uddeIM 2.3

Most of these are probably irrelevant, but I just updated the site with the latest components. Decided to address the spam issue and your plugin was the only joomla extension I could find to address the spam issue tons of us Joomla admins must deal with.

I looked at BadBehaviour but it wasn't a Joomla component. A component was made with it for Joomla 1.0, but it doesn't appear to be maintained.

So I'll keep looking at RV to figure out why it is rejecting registrations.

From what you say if I disconnected the net cable RV should NOT block the registration, so it should be straightforward isolating the culprit. I DO know it is RV because disabling the plugin allows registrations to go through.

Re: After installation how to use/configure it? 9 years, 8 months ago #1804

Have you enabled logging in RV? This will tell you exactly what RV is doing and why the registrations are being blocked. Set up logging in debug mode and absolutely everything will be logged.

Re: After installation how to use/configure it? 9 years, 8 months ago #1806

  • richmarx
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I tried that by putting /tmp/rvLog.txt into the logfile box, but didn't see anything in Joomla's tmp folder or the systems /tmp folder.

However, by changing the "stopforumspam" setting to match both IP and email seems to allow registration to proceed.

So how do you enable logging? I didn't see a checkbox or radio button to do so.
  • Page:
  • 1
Time to create page: 0.30 seconds
Copyright © 2009 www.cedit.biz. All rights reserved.